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I n t r o d u c t i o n
1. Introduction

With the Nokia Internet Modem application, you can access different 
internet services and define settings for your internet connection when 
the Nokia Internet Stick CS-15 is connected to your PC.

The application is installed on the PC when you use the CS-15 device for 
the first time. For details, see the quick start guide of the CS-15 device.

Read this guide carefully. Also read the quick start guide of the CS-15 
device and the user guides for your PC, operating system, and any PC 
software you use with the internet connection set up through the CS-15 
device.

For the latest guides, additional information, downloads, and services 
related to your Nokia product, see www.nokia.com/support or your local 
Nokia website.

Before you use the internet services described in this guide, contact your 
service provider for information about data transmission charges.
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G e t  s t a r t e d
2. Get started

■ Main view
To open the Nokia Internet Modem application, connect the CS-15 
device to a USB port on your PC, or start the application in the normal 
way in your operating system (for example, in Microsoft Windows XP, 
select Start > Programs > Nokia Internet Modem > Nokia Internet 
Modem). The main view of the application is displayed.

The main view shows the signal strength of your service provider in your 
current location (the more bars displayed, the better the signal), the 
name of the service provider you are using, and the type of the cellular 
network (such as HSDPA). The view may also contain shortcuts, for 
example, for different websites or applications. Depending on your 
service provider, the view may show information about the network cell 
that the CS-15 device is using.

The main view contains the following features:

• To create a shortcut for a website, application, or file, select Create 
shortcut. For details, see “Shortcuts”, p. 6.

• To open this guide, select Help. The guide is displayed in the PDF 
reader application installed on your PC.

• To minimise the application to the Windows taskbar without ending 
the active connection, select . To open the application window, 
click the application icon in the taskbar.

• To minimise the application to the Windows system tray without 
ending the active connection, select X. To open the application 
window, click the application icon in the system tray, and select 
Open.

• To use tools or define settings, select Options > Settings.... For 
details, see “Tools and settings”, p. 13.
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S h o r t c u t s
3. Shortcuts

The main view may contain predefined shortcuts to websites, 
applications, or files. You can also create new shortcuts.

■ Predefined shortcuts
To send and receive text messages or manage contacts, select . For 
details, see “Messages and contacts”, p. 8.

To send and receive e-mail using your default e-mail application, select 
. The network connection is set up using the default connection 

profile, and the e-mail application opens. For details, see the 
instructions for the e-mail application.

To browse web pages using your default internet browser, select . 
The network connection is set up using the default connection profile, 
and the browser opens. For details, see the instructions for the browser.

To connect to the internet using the default connection profile, select 
. To close a connection, select .

For information about connection profiles, see “Connection settings”, 
p. 14.

■ Create a new shortcut
1. In the main view, select Create shortcut, or select Options > 

Settings... > Shortcuts > Add.

2. In Shortcut name:, enter a name for the shortcut.

3. In Type of application:, select the type of the application that opens 
when you select the shortcut:

• Application or command line to be run — Select this option to 
define the web page, application, or file that opens when you 
select the shortcut.

• Default Internet browser — Select this option if you want that 
selecting the shortcut opens your default internet browser.
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S h o r t c u t s
• Default Internet messaging system — Select this option if you 
want that selecting the shortcut opens your default messaging 
application.

4. In Enter the name of an application, file or Internet link:, enter the 
application or file name or the address of a web page, or select 
Browse..., the file name, and Open. 

This field is active only if you selected Application or command line to 
be run.

5. In Associated connection, select None to use the shortcut with any 
connection profile, or select Connect using the profile: and the profile 
with which the shortcut is used.

6. To save the settings, select OK.

■ Import or export a shortcut
To import a shortcut from a file, in the main view, select Options > 
Settings... > Shortcuts > Import..., the folder where the shortcut file is 
saved, the file, and Open.

To export a shortcut to a file, select Options > Settings... > Shortcuts > 
Export..., and the target folder. Enter a file name, and select Save.

■ Edit or delete a shortcut
To edit or delete a shortcut, in the main view, select Options > 
Settings... > Shortcuts. The shortcuts you have created are displayed as 
a list. The connection profile associated to the shortcut is shown under 
Connection.

To edit a shortcut, select the shortcut and Modify, and proceed as 
described in “Create a new shortcut”, p. 6. 

To delete a shortcut, select the shortcut and Delete.
7



M e s s a g e s  a n d  c o n t a c t s
4. Messages and contacts

■ Messages
To send and receive text messages, in the main view, select  to open 
Messages/Contacts, and select Messages.

Before you can send or receive text messages (network service), you 
must define the correct settings if they are not predefined. For the 
settings, contact your service provider. To define the settings, see 
“Message settings”, p. 12.

Message folders
The device saves received messages in the Inbox folder, sent messages in 
the Sent items folder, and deleted messages in the Deleted items folder. 
Messages that have not yet been sent are saved in the Outbox folder.

To retrieve new messages or send messages saved in the Outbox folder, 
select Send/Receive.

To edit and send a message you saved in the Drafts folder, double-click 
the message header. Alternatively, select the message and Actions > 
Edit SMS.... Proceed as described in “Write and send a message”, p. 9.

To view a message saved in the Inbox, Outbox, or Sent items folder, 
select the folder, and double-click the message header. Alternatively, 
select the message and Actions > View SMS....

To forward or reply to a message saved in the Inbox folder, select the 
message and Forward or Reply. Proceed as described in “Write and send 
a message”, p. 9.

To delete a message, select the message folder and message. Press the 
delete key on your PC keyboard. The message is moved to the Deleted 
items folder. To restore a deleted message, select Deleted items and the 
message, click the right mouse button, and select Restore.

To permanently delete all messages saved in the Deleted items folder, 
select Deleted items, click the right mouse button, and select Empty 
trash.
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M e s s a g e s  a n d  c o n t a c t s
Write and send a message
Your device supports the sending of text messages beyond the character limit for 
a single message. Longer messages are sent as a series of two or more messages. 
Your service provider may charge accordingly. Characters that use accents or 
other marks, and characters from some language options, take up more space, 
limiting the number of characters that can be sent in a single message. 

1. In Messages, select New SMS....

2. In the To... field, enter the phone numbers of the recipients. Separate 
the recipients with a semicolon (;).

To select a stored recipient, select To..., the phonebook and contact 
folder, the contact in Contact list, Add > (to add the contact to 
Recipient list) or Add All >> (to add all the listed contacts to 
Recipient list), and OK.

Tip: To select several contacts in Contact list, press and hold 
the control key (Ctrl) on your PC keyboard while you select the 
recipients.

To remove contacts from Recipient list, select < Remove to remove 
the selected contact or << Delete all to remove all the contacts.

3. In the Text: field, write the message.

To edit the message, you can use the functions in the Edit menu. 
Undo cancels the last action. Select all selects the whole message.

4. To request the network to send you a delivery report of the message 
you have sent (network service), select Request a delivery report..

To select how the receiving device handles the sent message (if the 
receiving device supports this setting), select Class: and the desired 
option.

For details, see “Message settings”, p. 12.

5. To send the message, select Send.

To save the message to send it later, select Save. The message is 
saved in the Drafts folder.
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M e s s a g e s  a n d  c o n t a c t s
■ Contacts
To manage contacts saved on your SIM card, the CS-15 device, or the 
external phonebook you have selected in the contact settings, in the 
main view, select  to open Messages/Contacts, and select Contacts.

The contacts saved on the SIM card are shown in the SIM card folder, 
and the contacts saved in the CS-15 device are shown in the USB 
modem memory folder. The contacts saved in the external phonebook 
are shown in the respective folder.

Synchronise contacts
To synchronise contacts between the contact folders, in Contacts, select 
Update. After synchronisation, the same contacts are shown in the 
folders.

To select the synchronisation method, see “Contact settings”, p. 11.

Manage contacts
To add a new contact, in Contacts, select the desired contact folder and 
New contact.... Enter a name and phone number for the contact, and 
select OK.

To edit a contact, select the contact and Modify.

To delete a contact, select the contact and Delete. The contact is moved 
to the Deleted items folder.

To restore a deleted contact, select Deleted items, and drag the contact 
to the desired folder.

To copy a contact, select the contact, Edit > Copy, the target folder, and 
Edit > Paste.

To convert the phone number of a contact into the international format, 
select the contact, Actions > Internationalize numbers..., the country for 
the country code, and Internationalize. You can dial the number without 
adding the international access and country code in front of the phone 
number.

To send a text message to a contact, select the contact and Send SMS. 
To select several contacts, press and hold the control key (Ctrl) on your 
10



M e s s a g e s  a n d  c o n t a c t s
PC keyboard while you select the contacts. Proceed as described in 
“Write and send a message”, p. 9.

To send the phone number of a contact in a text message, select the 
contact and Actions > Send the number in an SMS....

To delete contacts that have the same name and phone number from a 
contact folder, select the contact folder and Actions > Remove 
duplicates.... Follow the displayed instructions.

Import or export contacts
To import contacts from a file, in Contacts, select the contact folder 
where you want to add the contacts and File > Import contacts.... Select 
the folder where the contact file is saved, the file, and Open.

To export contacts to a file, in Contacts, select the contact folder that 
contains the contacts and File > Export contacts.... Select the target 
folder, enter a file name, and select Save.

■ Settings for messages and contacts
To define message and contact settings, in the main view, select  and 
Tools > Settings... > Messages/Contacts.

Contact settings
To define the contact settings, select Contacts.

To select the external phonebook you want to use, select the desired 
option from the list. If you select None, no external phonebook can be 
accessed in Messages/Contacts.

To select how your contacts are synchronised between the CS-15 device 
and your SIM card, in Synchronization, select the desired option. If you 
select Automatic, the CS-15 device automatically synchronises the 
contacts when you select Contacts in Messages/Contacts. If you select 
Ask User, the device asks whether you want to synchronise the contacts. 
If you select Manual, you must select Update in Messages/Contacts to 
synchronise the contacts. See also “Synchronise contacts”, p. 10.
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M e s s a g e s  a n d  c o n t a c t s
Message settings
To define the message settings, select Messages.

To request the network to send you a delivery report of the text 
messages you have sent (network service) by default, in Short messages 
(SMS), select the Request a delivery report. checkbox.

To select how sent messages are handled on receiving devices (if the 
devices support this setting), in Short messages (SMS), select Class: and 
the desired option. If you select [0] Screen, the sent message is displayed 
on the receiving device but not saved in it. If you select [1] Phone 
Memory, the message is saved in the receiving device. If you select [2] 
SIM card, the message is saved on the SIM card of the receiving device. 
If you select [3] Default, the message is saved in the default location 
defined in the receiving device. If you select No class, the CS-15 device 
does not use any specific service class for sending text messages.

To select how long the message centre resends your message if the first 
attempt fails (network service), in Short messages (SMS), select Validity 
period: and the desired option. If the message cannot be sent within the 
period, the message is deleted from the message centre.

To enter the phone number of the message centre that delivers your text 
messages, select Service center, and enter the phone number you have 
obtained from your service provider. By default, the CS-15 device uses 
the message centre of the service provider whose connection profile you 
use for the connection.

To select whether the CS-15 device automatically retrieves new 
messages from the message centre or sends messages saved in the 
Outbox folder, in Synchronization, select the desired option. If you 
select Automatic, the CS-15 device automatically retrieves and sends 
the messages. If you select Ask User, the device asks whether you want 
to retrieve and send the messages. If you select Manual, you must select 
Send/Receive in Messages/Contacts to retrieve and send the messages.
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T o o l s  a n d  s e t t i n g s
5. Tools and settings

■ Tools
To use different tools, in the main view, select Options.

To connect to the internet, select Connections (Dial-up) and the 
connection profile you want to use.

To change the service provider for the connection, select Operator 
selection... > Manual selection and the provider. You can only select a 
provider whose status is Enabled. To let the CS-15 device select the 
provider automatically, select Automatic selection. To return to the 
main view, select Select.

To select which type of network the device uses for the connection, 
select Network type selection and the network type. If you select 
Automatic selection (WCDMA first), the CS-15 device first tries to use a 
UMTS network, and if this fails, a GSM network. If you select WCDMA 
only or GSM only, the CS-15 device only tries to use the given network 
type. If you select GSM first, the CS-15 device first tries to use a GSM 
network.

To view information about previous connections, select Connection 
history.... You can view the service provider name, connection date and 
duration, total amount of data sent and received during the session, 
amount of sent and received data, average transmission rate of received 
(Avg. rate in) and sent (Avg. rate out) data, and maximum transmission 
rate of received and sent data. To delete the selected line, select 
Remove. To delete the entire history, select Clear. To save the history as 
a file on your PC, select Export....

To view information about the application, select About....

■ General settings
To define general settings, in the main view, select Options > 
Settings... > General.
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T o o l s  a n d  s e t t i n g s
To set the application to start automatically when you log onto the 
operating system, select the related checkbox. If the checkbox is not 
selected, to use the application, you must open it manually in the 
operating system.

To change the language for the Nokia Internet Modem application, 
select Language and the language.

To select the action that is performed when you connect the CS-15 
device to your PC, select Do nothing if you do not want to perform any 
action, Explore the device (contacts, SMS, ...) to open Messages/
Contacts, or Connect to the Internet to connect to the internet using the 
default connection profile. To set the application to ask for the action, 
select Always ask.

■ Connection settings
The CS-15 device has predefined settings for several service providers. 
The settings are grouped in connection profiles.

If the CS-15 device cannot detect your service provider or the 
connection does not work correctly in the network of the provider you 
have selected, you can edit a predefined connection profile or create a 
new one.

Manage connection profiles
To manage connection profiles, in the main view, select Options > 
Settings... > Connections (Dial-up). The current profiles are displayed as 
a list. Do one of the following:

• To set a profile as default, select the profile and Default.

• To copy and modify a predefined profile (indicated with a padlock), 
select the profile and Copy and modify. Define the required settings; 
for details, see “Create a new connection profile”, p. 15.

• To edit a profile you have created, select the profile and Modify.

• To delete a profile you have created, select the profile and Delete. 
Predefined profiles cannot be deleted.

• To export or import a profile, select Files and the desired option.
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T o o l s  a n d  s e t t i n g s
• To add a predefined profile to the profile list, select New > Use a 
predefined connection. > Next >, the country of the service provider, 
and the operator (service provider). In Select the desired profile(s):, 
select the predefined profile of the service provider. To save the 
settings, select Finish.

• To copy and edit a predefined profile, select New > Copy and modify 
a predefined connection. > Next >. Select the desired options and 
Next >. Define the required settings. For details, see “Create a new 
connection profile”, p. 15.

Create a new connection profile
To create a new connection profile, in the main view, select Options > 
Settings... > Connections (Dial-up) > New > Create a new connection., 
and the desired network type, if the service provider offers several types. 
Select Next >, and define the following settings:

• In Choose a name for this connection:, enter a name for the profile. In 
Access point name (APN), enter the name you obtained from the 
service provider. In Authenticating, enter the user name, password, 
and domain you obtained from the service provider.

• To define the domain name server (DNS) and proxy servers, select 
DNS/Proxy. 

To set the device to fetch the DNS server address automatically, 
select Get the DNS server address automatically.. 

To use a specific server address, select Use the following DNS server 
addresses:, and enter the IP address of the primary and (optionally) 
secondary DNS. 

To use an HTTP proxy, select Use an HTTP proxy., and enter its IP 
address and port number.

To save the profile, select Finish.
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T o o l s  a n d  s e t t i n g s
■ PIN code settings
The personal identification number (PIN) code or the universal personal 
identification number (UPIN) code (4 to 8 digits) helps to protect your 
SIM card. The (U)PIN code is usually supplied with the SIM card.

To define PIN code settings, in the main view, select Options > 
Settings..., and the device name.

To change the (U)PIN code of your SIM card, select Change SIM PIN 
code. In the Previous SIM PIN code: field, enter the current code. In the 
New SIM PIN code: and Confirm new SIM PIN code: fields, enter the new 
code.

To set the CS-15 device to request the (U)PIN code each time the device 
is connected to the PC, select Enable/disable PIN code > Enabled.

■ Other settings
To manage shortcuts you have created, in the main view, select 
Options > Settings... > Shortcuts. For details, see “Shortcuts”, p. 6.

To define settings for Messages/Contacts, in the main view, select 
Options > Settings... > Messages/Contacts. For details, see “Settings for 
messages and contacts”, p. 11.

To edit the name of the CS-15 device shown in the Nokia Internet 
Modem application, in the main view, select Options > Settings..., the 
device name, and Device settings. Enter the name that you want to be 
displayed for the device.
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